Calypso Kid
Aspiring developer
Profile
Posts: 689
Reg: Mar 09, 2012
Upstate New Yor...
17,290
03/07/17 08:23 PM (2 weeks ago)

You can’t use this version of the application “Xcode-beta” with this version of OS X.

Hello all,

This is a first for me. I usually download the beta versions of xcode to play with. My old MacBook Pro is using OS X El Capitan Version 10.11.6. I cannot upgrade the OS to Sierra because my computer is too old and the App Store won't allow it.

I just downloaded Xcode 8.3 beta and got this after I expanded the download to install it:

You can’t use this version of the application “Xcode-beta” with this version of OS X.
You have OS X 10.11.6. The application requires OS X 10.12 or later.

On top of that, I already installed the beta version of iOS 10.3 on my phone and Xcode 8.2.1 (the latest public release) and will not install apps for testing onto 10.3.

Not sure if this is going to block everyone with older computers from uploading new apps to the App Store.

I'll have to do a little digging to see what the future holds for older computers. It's a shame because my nearly 10 year old Macbook Pro runs pretty good!

Dave


Found this in the release notes for Xcode 8.3 beta

About Xcode 8.3 beta 3
Supported Configurations
Xcode 8.3 beta 3 requires a Mac running macOS 10.12 or later.
Xcode 8.3 beta 3 includes SDKs for iOS 10.3, watchOS 3.2, macOS 10.12.4, and tvOS 10.2.
 

Login + Screen Name Required to Post

pointerLogin to participate so you can start earning points. Once you're logged in (and have a screen name entered in your profile), you can subscribe to topics, follow users, and start learning how to make apps like the pros.