Discussion Forums  >  Self Hosted Control Panels

Replies: 5    Views: 114

Alessandro
Aspiring developer
Profile
Posts: 68
Reg: Nov 13, 2012
São Paulo
12,180
08/07/16 05:45 AM (1 year ago)

Self hosted error when creating new app

Hi,

I installed BT self hosted and everything is working fine. I was able to login, navigate, install plugins from my buzztouch.com control panel and I can see in the database that tables are being filled with the actions I do in the BT self hosted control panel.

But, when I try to create a new app, I get this error code:
"An error ocurred in running the fnExecuteNonQuery() method in utilityFunctions.php (6)"

- I already reinstalled BT self hosted, recreated the database but still the same error;
- I changed to PHP 5.4 as Dusko suggested but still the same error;
- Tried changing to "localhost" in APP_DB_HOST as is shown in some posts, but then the self hosted control panel didn't load anymore showing an error code, then I put back to the server url as shown bellow;
- When I access the database, I can notice that data from the self hosted software was loaded there, for example, the table with plugins show all plugins that I installed. So I believe that database parameters in config.php are ok.

This is how I set config.php:

/* database server information. Enter your database login credentials here. */
define("APP_DB_HOST", "buzztouch.mysql.uhserver.com");
define("APP_DB_NAME", "buzztouch");
define("APP_DB_USER", "buzztouch");
define("APP_DB_PASS", "XXXX");

/* buzztouch.com User Email Address, Password */
define("APP_BT_ACCOUNT_USEREMAIL", "XXXX");
define("APP_BT_ACCOUNT_USERPASS", "XXXX");

/* buzztouch.com API URL, API Key, API Secret. Log in at buzztouch.com then see Account > Self Hosted Servers */
define("APP_BT_SERVER_API_URL", "https://www.buzztouch.com/api");
define("APP_BT_SERVER_API_KEY", "XXXXX");
define("APP_BT_SERVER_API_KEY_SECRET", "XXXX");

/* application URL. Do not enter the trailing slash (/) after any URL. */
define("APP_URL", "http://www.lokobeer.com.br/buzztouch");

/* application physical path on server, data directories. */
/*These begin with a forward slash (/). Do not enter the trailing slash (/) */
define("APP_PHYSICAL_PATH", "/var/www/html/lokobeer.com.br/web/buzztouch");
define("APP_DATA_DIRECTORY", "/files");
define("APP_THEME_PATH", "/files/theme");


What can I try to do next?

Thanks!
 
SmugWimp
Smugger than thou...
Profile
Posts: 6250
Reg: Nov 07, 2012
Tamuning, GU
80,750
like
08/08/16 09:36 PM (1 year ago)
1) Make sure your Buzztouch API key is correct, and credentials match the same IP/Domain as registered.
2) "App Physical Path" is a biggie. Ensure it's correct, or you'll get all kinds of weirdness.
3) APP_DB_Host is usually either 'localhost' (you tried that) or IP Address, or FQDN. Ensure blah blah...

Otherwise, things 'should' work ok. Not working is usually something simple. The problem is, there are only a few dozen 'simple' things that need to be checked, lol!

Good luck, and let us know how it works out. Don't fret; It works for us... it can work for you too. Just need to nail down a few details here and there...

Cheers!

-- Smug
 
Alessandro
Aspiring developer
Profile
Posts: 68
Reg: Nov 13, 2012
São Paulo
12,180
like
08/09/16 06:30 PM (1 year ago)
Hi Smug, thanks for the suggestions!

1) Checked again API key and IP/Domains, that's ok;
2) Checked App physical path using BT_Path.php that I found in this link: http://littlespace.com/if-faq/175/app_physical_path-finder/
3) In APP_DB_Host I'm using the database server url. Using the same parameters I'm able to access this database from Sequel Pro program in my computer. I noticed that everyone uses "localhost", but that didn't work for me... The problem is probably in APP_DB_Host, but I can't figure out how to set this parameter according to my server. I didn't try using IP address, I'll test it.

Cheers!
 
SmugWimp
Smugger than thou...
Profile
Posts: 6250
Reg: Nov 07, 2012
Tamuning, GU
80,750
like
08/09/16 06:32 PM (1 year ago)
A good number of us use 'hostgator' as our hosting provider. That's why a lot of us use 'localhost', because that is what works for us. Your provider may be different of course.

If you're absolutely positively sure that all your values are correct, I'd try regenerating a new BT API Key and using that.

Cheers!

-- Smug
 
Alessandro
Aspiring developer
Profile
Posts: 68
Reg: Nov 13, 2012
São Paulo
12,180
like
09/01/16 03:59 AM (1 year ago)
Hi Smug,

An update on this issue: I migrated from my host provider to HostGator, as suggested by Dusko, and it worked fine in their host. The issue on creating new apps does not happen anymore.

It took some weeks to conclude the migration and check if all other programs I had there were still working, then I was able to install BT self hosted in the new server e test this issue.

Thanks for your help!
 
SmugWimp
Smugger than thou...
Profile
Posts: 6250
Reg: Nov 07, 2012
Tamuning, GU
80,750
like
09/01/16 06:41 AM (1 year ago)
Glad you got it working! :)

Cheers!

-- Smug
 

Login + Screen Name Required to Post

pointerLogin to participate so you can start earning points. Once you're logged in (and have a screen name entered in your profile), you can subscribe to topics, follow users, and start learning how to make apps like the pros.